CampSite phone support unavailable
Incident Report for CampSite
Resolved
Thank you for your patience - our support office is now closed. CampSite phone support will resume tomorrow morning at 8:30am.
Posted Mar 14, 2016 - 17:37 EDT
Identified
Due to a power outage at our main office, phone support for CampSite is temporarily unavailable. Please submit a ticket to support@campmanagement.com or via the ZenDesk portal if you have any support questions or issues. We will update this page when phone support is restored.
Posted Mar 14, 2016 - 16:37 EDT