CampSite is currently experiencing issues with payment processing

Incident Report for CampSite

Resolved

The 3rd party provider has confirmed full restoration of the payment gateway. The incident has been resolved. We apologize for any inconvenience this might have caused.
Posted Mar 02, 2026 - 19:00 EST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 13:28 EST

Monitoring

A fix has been implemented at the partner level. We are currently monitoring the results. We will share another update as soon as more progress is made. Thank you for your patience.
Posted Mar 02, 2026 - 12:02 EST

Identified

The issue has been identified at the partner level and a fix is actively being working on. We appreciate your patience while we work with the processor for full restoration.
Posted Mar 02, 2026 - 11:04 EST

Investigating

We are currently investigating an issue with one of our payment processing partners. We will update when we have more information. Thank you for your patience
Posted Mar 02, 2026 - 09:45 EST
This incident affected: CampSite.