Payment Gateway issue effecting some users

Incident Report for CampSite

Resolved

This incident has been resolved. Seems that there was an issue at the payment gateway level which has been addressed on the providers end. We will of course monitor for the next 24 hours. Once again we appreciate your patience and apologize for any inconvenience this might have caused
Posted May 26, 2026 - 14:41 EDT

Monitoring

We are currently monitoring the implemented fix. Once we are sure it is stable well will resolve the case. We thank you for your patience with this issue
Posted May 26, 2026 - 14:05 EDT

Identified

The issue has been Identified and a fix has been deployed. We will will observe the implemented fix and update accordingly.
Posted May 26, 2026 - 13:34 EDT

Investigating

We are currently investigating the issue. We will update appropriately.
Posted May 26, 2026 - 12:49 EDT
This incident affected: CampSite.