CampSite is experiencing slow load times due to an AWS issue

Incident Report for CampSite

Resolved

This incident has been resolved. We apologize for any inconvenience this might have caused
Posted Aug 21, 2025 - 19:01 EDT

Monitoring

A fix has been implemented. The lag seems to be mitigated and returning to normal. We will continue to monitor for the next hour or so before marking this as resolved. We thank you for your patience.
Posted Aug 21, 2025 - 18:08 EDT

Identified

We were recently made aware of an issue with our AWS Cloud network provider. They are currently investigating a connectivity issue. We will update accordingly on resolution to this issue.
Posted Aug 21, 2025 - 16:22 EDT
This incident affected: CampSite.